Wordpres 5.4.2 – Custom Fields und qTranslate-X Problem

Hier ein Fehler der in dieser Form vermutlich bei vielen Auftritt, welche qTranlate Plugin im Einsatz haben.Die Ursache ist eine veraltete qTranslate Erweiterung. Diese spielt in unserem Fall nicht korrekt mit ACF Erweiterung für Custom Fields zusammen.

WordPress-Version 5.4.2

Aktuelles Plugin: qTranslate-X (Version 3.4.6.8)

PHP-Version 7.2.10

 

Fehler-Details

==============

Ein Fehler vom Typ E_ERROR wurde in der Zeile 32 der Datei /html/wordpress/wp-content/plugins/qtranslate-x/admin/qtx_admin.php verursacht. Fehlermeldung: Uncaught Error: Only variables can be passed by reference in /html/wordpress/wp-content/plugins/qtranslate-x/admin/qtx_admin.php:32

Stack trace:

#0 /html/wordpress/wp-content/plugins/qtranslate-x/admin/qtx_admin.php(32): qtranxf_collect_translations(Array, ”, ‘de’)

#1 /html/wordpress/wp-content/plugins/qtranslate-x/admin/qtx_admin.php(85): qtranxf_collect_translations(Array, Array, ‘de’)

#2 /html/wordpress/wp-includes/class-wp-hook.php(287): qtranxf_collect_translations_posted(”)

#3 /html/wordpress/wp-includes/class-wp-hook.php(311): WP_Hook->apply_filters(NULL, Array)

#4 /html/wordpress/wp-includes/plugin.php(478): WP_Hook->do_action(Array)

#5 /html/wordpress/wp-settings.php(403): do_action(‘plugins_loaded’)

#6 /html/wordpress/wp-config.php(118): require_once(‘/html/wordpress…’)

#7 /html/wordpress/wp-load.php(37): require_once(‘/html/wordpress…’)

#8 /html/wordpress/wp-admin/admin.php(34): require_once(‘/html/wordpress…’)

#9 /html/wordpress/wp-admin/post.php(12): require_once(‘/html/wordpress…’)

#10

 

Kompletter WordPress Fehler nach Aktivierung debug

Warning: Illegal string offset ‘acfcloneindex’ in /html/wordpress/wp-content/plugins/qtranslate-x/admin/qtx_admin.php on line 32

Fatal error: Uncaught Error: Only variables can be passed by reference in /html/wordpress/wp-content/plugins/qtranslate-x/admin/qtx_admin.php:32 Stack trace: #0 /html/wordpress/wp-content/plugins/qtranslate-x/admin/qtx_admin.php(32): qtranxf_collect_translations(Array, ”, ‘de’) #1 /html/wordpress/wp-content/plugins/qtranslate-x/admin/qtx_admin.php(85): qtranxf_collect_translations(Array, Array, ‘de’) #2 /html/wordpress/wp-includes/class-wp-hook.php(288): qtranxf_collect_translations_posted(”) #3 /html/wordpress/wp-includes/class-wp-hook.php(312): WP_Hook->apply_filters(NULL, Array) #4 /html/wordpress/wp-includes/plugin.php(478): WP_Hook->do_action(Array) #5 /html/wordpress/wp-settings.php(392): do_action(‘plugins_loaded’) #6 /html/wordpress/wp-config.php(118): require_once(‘/html/wordpress…’) #7 /html/wordpress/wp-load.php(37): require_once(‘/html/wordpress…’) #8 /html/wordpress/wp-admin/admin.php(34): require_once(‘/html/wordpress…’) #9 /html/wordpress/wp-admin/post.php(12): require_once(‘/html/wordpress…’) #10 in /html/wordpress/wp-content/plugins/qtranslate-x/admin/qtx_admin.php on line 32

 

Lösung für WordPress Fehler

Die Lösung gibt es glücklicherweise auch. Es haben andere Entwickler das Plugin übernommen und stellen dafür Updates bereit.

Die Erweiterung sowie Anleitung zur Installation gibt es hier

https://github.com/qtranslate/qtranslate-xt

 

Es hat geholfen? Gerne in die Kommentare

 

Sie benötigen Untersützung bei WordPress?

weitere Informationen zu WordPress Betreuung von KonVis gibt es hier

mehr zu WordPress Internetseiten gibt es hier

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.