Shopware 6 Problem – offizielle Dockerfile im Shopware production repository verwendet php 7.3

Wir hatten ein mehr als nerviges bei Shopware 6. Der Shop lief auf einer lokalen Instanz nicht.

Es äußerte sich darin, dass die Startseite defekt war und andere Probleme wie ein nicht erscheinender Fußbereich.

Die Ursache war, dass die offiziele Dockerfile von Shopware verwendet PHP 7.3. Die PHP Version ist veraltet und führt auf aktuellem Server leider zu Problemen.

Lösung war eine Anpassung der PHP Version, sodass das Docker File PHP 7.4 verwendet.

Shopware selbst setzt jedoch auch bereits auf PHP 7.4 bzw. neuere Version. Die offzielle Dockerfile war/ist (20.05.2021) leider nicht korrekt und so nicht nutzbar bzw. muss angepasst werden.

https://docs.shopware.com/de/shopware-6-de/erste-schritte/systemvoraussetzungen 

mehr zu Shopware 6 gibt es hier

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.